Ecere SDK/eC Forums • View topic - 新建工程后遇到的问题




Ecere SDK/eC Forums

Ecere Developers Community

新建工程后遇到的问题

来自中国的朋友,欢迎您在本版面使用中文讨论问题。请注意,如果您想得到不懂中文的人的帮助,请同时提供英文译文。
Help and discussions in Chinese.

新建工程后遇到的问题

Postby Robin Chen » Tue Jul 28, 2015 7:08 am

在我新建一个项目,并执行运行后,输出栏提示“无法打开 obj\debug.win32\main.sys”,进入项目文件夹中查看得知,Ecere创建了一个名为“objdebug.win32”无子文件夹的文件夹,根据文件夹名可以推出在创建文件夹路径时少了“\”符号。如下图所示:

Ecere.png
问题1


按其规律修改文件夹结构后后开始重新运行,在运行过程中出现假死现象,持续10分钟以上不见好转。且只有在项目菜单下停止创建后,才能关闭窗口。如下图所示:

Ecere2.png
问题2


希望能够及时修改,谢谢!

当前环境:
Win XP SP3 32位
Ecere 中文界面


-------------------------【 分 割 线 】---------------------------------


I create a new project, and execute the run, the output field "Unable to open the obj \ debug.win32 \ main.sys", into the project folder view that, Ecere create a group called "objdebug.win32" no child file folders, according to the folder name can be introduced when creating the folder path less "\" symbol. As shown below:

Amend their laws after the folder structure began to re-run, the phenomenon of suspended animation during operation for 10 minutes did not improve. Under the Project menu and only stop creation, in order to close the window. As shown below:



Hoping to be revised, thank you!

The current environment:
Win XP SP3 32 bit
Ecere Chinese interface
Robin Chen
 
Posts: 16
Joined: Mon Jul 27, 2015 8:03 am

Re: 新建工程后遇到的问题

Postby jerome » Tue Jul 28, 2015 11:17 am

Hi there,

Again, forgive me for replying in English only :)

I have seen a similar problem before, however I am not sure we ever figured out the cause of the problem.

One thing to look for is whether the right mingw32-make.exe is being used.

It should be (mingw32-make --version):

GNU Make 3.82.90
Built for i686-w64-mingw32

177 KB (181,760 bytes)

Note that the extension it is looking for is .sym, not .sys.

“objdebug.win32” -- this is missing a / character.
I am really not sure however how that / ended up missing...
The most likely issue is using a wrong mingw32-make, or having another conflicting executable in your path, like a 'sh.exe' in your PATH e.g. from Git's bin folder)

Regards,

-Jerome
jerome
Site Admin
 
Posts: 614
Joined: Sat Jan 16, 2010 11:16 pm

Re: 新建工程后遇到的问题

Postby Robin Chen » Tue Jul 28, 2015 8:27 pm

Hi Jerome:
首先谢谢你的及时回复!
我会根据你提供的信息去尝试自己找到解决的方法,将在稍后的时间里再提交我的经验吧。

另外想提一个建议:
希望软件对话框中的各参数的设置项能给个气泡提示就更好了,有时知道这是什么参数,但不知道如何填写或选择,使人困惑!

Regards,

-Rogin Chen

------【 google 翻译中/英文分割线 (google translation Chinese/ English dividing line) 】-------

Hi Jerome:
First of all thank you for your prompt reply!
I will be based on the information you provide to try to find their own solutions, will submit my experience it at a later time.

Also I would like to make a suggestion:
We hope the software settings dialog the parameters give a bubble prompted the better, sometimes know what this argument, but I do not know how to fill in or choose confusing!

Regards,

-Rogin Chen
Robin Chen
 
Posts: 16
Joined: Mon Jul 27, 2015 8:03 am

Re: 新建工程后遇到的问题

Postby jerome » Tue Jul 28, 2015 8:30 pm

I really suggest you install using the Windows installer first.
It should set up the global settings for you automatically.

https://launchpad.net/ecere/trunk/0.44. ... -win32.exe
jerome
Site Admin
 
Posts: 614
Joined: Sat Jan 16, 2010 11:16 pm

Re: 新建工程后遇到的问题

Postby Robin Chen » Thu Jul 30, 2015 12:10 am

jerome wrote:Hi there,

Again, forgive me for replying in English only :)

I have seen a similar problem before, however I am not sure we ever figured out the cause of the problem.

One thing to look for is whether the right mingw32-make.exe is being used.

It should be (mingw32-make --version):

GNU Make 3.82.90
Built for i686-w64-mingw32

177 KB (181,760 bytes)

Note that the extension it is looking for is .sym, not .sys.

“objdebug.win32” -- this is missing a / character.
I am really not sure however how that / ended up missing...
The most likely issue is using a wrong mingw32-make, or having another conflicting executable in your path, like a 'sh.exe' in your PATH e.g. from Git's bin folder)

Regards,

-Jerome



Hi Jerome,
今天按照你给的格式修改了“mingw32-make”的文件夹名称,我原来的名称为直接解压文件夹后得到的名称“make-3.82.90-20111115”,经修改后,去掉了名称后面的“-20111115”,问题得到了解决,非常感谢!

Regards,

-Robin Chen

------【 google 翻译中/英文分割线 (google translation Chinese/ English dividing line) 】-------

Hi Jerome,
Today, according to the format you modify the "mingw32-make" of the folder name, my original name after the name of the folder directly extract obtained "make-3.82.90-20111115", as amended, removed the back name "-20111115", the problem has been resolved, thank you very much!

Regards,

-Robin Chen
Robin Chen
 
Posts: 16
Joined: Mon Jul 27, 2015 8:03 am


Return to 欢迎使用中文讨论

Who is online

Users browsing this forum: No registered users and 8 guests

cron