View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000576Ecere SDKcompilerpublic2010-10-31 07:092014-02-22 18:29
Reporterredj 
Assigned To 
PriorityimmediateSeveritytweakReproducibilityN/A
StatusnewResolutionopen 
PlatformCross-PlatformOS\o/OS Version;-)
Product Version 
Target Version0.46 eC IIFixed in Version 
Summary0000576: bad import pattern slows compilation of pannels flles
Descriptionthe panels are importing the ide.ec file which is causing slow compiles on those short files

ide.ec should import the panels but not the other way around
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000399)
redj (administrator)
2010-10-31 07:12

Added revision 160 to sdk/ide/src/ide.ec
Added revision 59 to sdk/ide/src/dialogs/FindInFilesDialog.ec
Added revision 36 to sdk/ide/src/panels/CallStackView.ec
Added revision 35 to sdk/ide/src/panels/OutputView.ec
Added revision 29 to sdk/ide/src/panels/ThreadsView.ec
(0000401)
jerome (administrator)
2010-11-24 18:22

Why does importing IDE slow things down?

All it does is read up the sym files, this should all be very fast.

More important should be trying to figure out the cause of this slowdown.
Profiling of the IDE compilation?
(A simple debug/break while it's running might give a hint)
(0000515)
redj (administrator)
2012-03-08 14:52

we'll see how things evolve after the release of Haste

- Issue History
Date Modified Username Field Change
2010-10-31 07:09 redj New Issue
2010-10-31 07:09 redj Status new => assigned
2010-10-31 07:09 redj Assigned To => redj
2010-10-31 07:12 redj Note Added: 0000399
2010-11-24 18:22 jerome Note Added: 0000401
2012-03-08 14:52 redj Note Added: 0000515
2012-03-08 14:52 redj Resolution open => won't fix
2012-03-08 15:41 redj Target Version old 0.44.pre2 => 0.45 Ginkakuji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2012-03-29 08:47 redj Summary ide: pannels: bad import pattern slows compilation => bad import pattern slows compilation of pannels flles
2013-04-24 07:50 jerome Resolution won't fix => open
2013-04-24 20:30 jerome Assigned To redj =>
2013-04-24 20:35 jerome Status assigned => new
2013-04-25 20:12 jerome Target Version 0.45 Ginkakuji => 0.44.7 Haste
2014-02-22 18:29 jerome Category ide => compiler



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker